Files | Admin

Notes:

Release Name: 1.9.2-p290

Notes:
Ruby 1.9.2-p290 release

MD5 for verification:

0531aa59ab628e34d593916c4b3c01fe *ruby-1.9.2-p290-doc-chm.7z
a9009c62f4da9bd936651cd7631eb283 *ruby-1.9.2-p290-i386-mingw32.7z
2ebae0cddbcc3176d145b59f3cc02c43 *rubyinstaller-1.9.2-p290.exe

Installer is also digitally signed to avoid alterations and UAC warnings.



Changes: Ruby's own announcement here: http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/385319 RubyInstaller own set of modifications * Enhancements: * Upgraded Ruby 1.9.2 to patchlevel 290 * Upgraded libyaml to 0.1.4 in Ruby 1.9 * Upgraded RubyGems to 1.7.2 on all versions of Ruby * Upgraded rb-readline to version 0.4.0 * Upgraded OpenSSL to 1.0.0d on all versions of Ruby * Build Ruby using GCC 4.5.2 (TDM-1 release) * Add support for Tcl/Tk 8.5.10 in recipes, installers, and archives * Change from MIT license to Modified BSD License (3-clause) * Deprecations: * Installers now enforces Windows XP as minimum OS. GH-54