Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread
Message: 97814
BY: Stephan Keller (skeller1)
DATE: 2012-05-02 14:20
SUBJECT: SQL Statement invalid (Rails,remote database)

 

Hi guys,

I have installed the ibm_db gems with version 2.5.7 - 2.5.10. Compiling wasn't the problem. All fine.

In Rails 3.1.0 - 3.2.3 I got this error after execute rake db:migrate:

RuntimeError: Failed to execute statement due to: [IBM][CLI Driver][IDS/UNIX64] A syntax error has occurred. SQLCODE=-201: SELECT FIRST schema_migrations.version FROM schema_migrations


The same by fetch all post models. In the end it's quite sure that the generated SQL has the wrong format. So my question:

Is this a configuration problem of odbc/cli drivers? or

Is it the wrong Rails version (changelog for ibm_db 2.5.10 announces Rails 3.2.3 support) ?


I have installed ibm_db under Windows 7 64 Bit and Ubuntu 10.04 LTS 32 Bit. Still the same problem.

Thank you

Stephan


ps: It's possible to write own SQL in ruby script with IBM_DB.exec....


Thread View

Thread Author Date
SQL Statement invalid (Rails,remote database)Stephan Keller2012-05-02 14:20
      RE: SQL Statement invalid (Rails,remote database)Praveen Devarao2012-05-02 17:35
            RE: SQL Statement invalid (Rails,remote database)Stephan Keller2012-05-02 19:32
                  RE: SQL Statement invalid (Rails,remote database)Stephan Keller2012-05-09 14:29
                        RE: SQL Statement invalid (Rails,remote database)Praveen Devarao2012-05-10 04:17
                              RE: SQL Statement invalid (Rails,remote database)Stephan Keller2012-05-10 05:21
                                    RE: SQL Statement invalid (Rails,remote database)Praveen Devarao2012-05-16 06:53
                                          RE: SQL Statement invalid (Rails,remote database)Stephan Keller2012-05-16 09:24
                                                RE: SQL Statement invalid (Rails,remote database)Praveen Devarao2012-05-16 09:42

Post a followup to this message