Forums | Admin

Discussion Forums: open-discussion

Start New Thread Start New Thread
Message: 58757
BY: Praveen Devarao (praveend)
DATE: 2008-07-23 05:20
SUBJECT: RE: Still Having To Patch Rails

 

Hi Philip,

Just clarifying, are you referring to the patch with respect to the reply to your post "Rails Won't Start With ibm_db as Database". Some details for you is as follows.
With the release of version 0.9.5 the activerecord patch that is been mentioned to be applied is to have has_belongs_to_many associations work properly. This is because Activerecord generates non-standard SQL, which databases like DB2 do not support, hence to work around this (only for activerecord-2.1.0)we have asked to have your activerecord patched. Coming to having the ibm_db adapter registered with the list of Rails Connection Adapters this is not required from the Rails version 2.0.0 and onwards.

Let me know if this is what you are looking for.

Thanks

Praveen


Thread View

Thread Author Date
Still Having To Patch Rails Philip Nelson2008-07-22 23:05
      RE: Still Having To Patch Rails Praveen Devarao2008-07-23 05:20
            RE: Still Having To Patch Rails Philip Nelson2008-07-23 23:21
                  RE: Still Having To Patch Rails Praveen Devarao2008-07-28 07:03
                        RE: Still Having To Patch Rails Praveen Devarao2008-10-02 13:31

Post a followup to this message