Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread
Message: 20690
BY: Aravind Elango (aelango)
DATE: 2007-04-13 15:12
SUBJECT: Unable to build sqlite3 from gem

 

Hi,

I tried to install sqlite3 and ran into trouble. Btw this is a shared hosting site computer.

Any advice?
Thanks,Aravind

$ gem install sqlite3-ruby-1.2.1.gem

Building native extensions. This could take a while...
ERROR: While executing gem ... (RuntimeError)
Error instaling sqlite3-ruby-1.2.1.gem:
ERROR: Failed to build gem native extension.

ruby extconf.rb install sqlite3-ruby-1.2.1.gem
checking for sqlite3.h... no

make
make: *** No rule to make target `ruby.h', needed by `sqlite3_api_wrap.o'. Stop.


Gem files will remain installed in ...../gems/sqlite3-ruby-1.2.1 for inspection.
Results logged to ...../sqlite3_api/gem_make.out


Thread View

Thread Author Date
Unable to build sqlite3 from gemAravind Elango2007-04-13 15:12
      RE: Unable to build sqlite3 from gemJosh Cronemeyer2007-04-17 16:13
      RE: Unable to build sqlite3 from gemMichael Hewner2009-04-12 11:07

Post a followup to this message