Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread
Message: 173514
BY: Max Mustermann (bugmenot2)
DATE: 2013-04-15 16:44
SUBJECT: oci8lib_200.so: [BUG] Segmentation fault

 

Hi, I have Segmentation fault on Windows 7 64x, ruby 2.0.0p0 (2013-02-24) [x64-mingw32]

It can be reproduced with simple command
ruby -e "require 'oci8'"

stack follows:

c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/gems/2.0.0/gems/ruby-oci8-2.1.5/lib/o
ci8lib_200.so: [BUG] Segmentation fault
ruby 2.0.0p0 (2013-02-24) [x64-mingw32]

-- Control frame information -----------------------------------------------
c:0009 p:-5384124 s:0043 e:000042 TOP [FINISH]
c:0008 p:---- s:0041 e:000040 CFUNC :require
c:0007 p:0073 s:0037 e:000036 METHOD c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/
2.0.0/rubygems/core_ext/kernel_require.rb:45
c:0006 p:0413 s:0027 e:000026 TOP c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/
gems/2.0.0/gems/ruby-oci8-2.1.5/lib/oci8.rb:81 [FINISH]
c:0005 p:---- s:0021 e:000020 CFUNC :require
c:0004 p:0059 s:0017 e:000016 BLOCK c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/
2.0.0/rubygems/core_ext/kernel_require.rb:110
c:0003 p:0286 s:0014 e:000013 METHOD c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/
2.0.0/rubygems/core_ext/kernel_require.rb:35
c:0002 p:0007 s:0004 E:000c68 EVAL -e:1 [FINISH]
c:0001 p:0000 s:0002 E:000458 TOP [FINISH]

-e:1:in `<main>'
c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_requir
e.rb:35:in `require'
c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_requir
e.rb:110:in `rescue in require'
c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_requir
e.rb:110:in `require'
c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/gems/2.0.0/gems/ruby-oci8-2.1.5/lib/o
ci8.rb:81:in `<top (required)>'
c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_requir
e.rb:45:in `require'
c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_requir
e.rb:45:in `require'

-- C level backtrace information -------------------------------------------
C:\Windows\SYSTEM32\ntdll.dll(NtWaitForSingleObject+0xa) [0x000000007709135A]
C:\Windows\system32\KERNELBASE.dll(WaitForSingleObjectEx+0x9c) [0x000007FEFD2B10
DC]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_vm_bugreport+0x9
d) [0x000000006F280C8D]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_name_err_mesg_ne
w+0x838) [0x000000006F141418]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_bug+0x45) [0x000
000006F1421C5]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_check_safe_str+0
x188) [0x000000006F2074E8]
[0x0000000000401A85]
C:\Windows\SYSTEM32\ntdll.dll(_C_specific_handler+0x9c) [0x00000000770585A8]
C:\Windows\SYSTEM32\ntdll.dll(RtlDecodePointer+0xbd) [0x0000000077069D0D]
C:\Windows\SYSTEM32\ntdll.dll(RtlUnwindEx+0xbbf) [0x00000000770591AF]
C:\Windows\SYSTEM32\ntdll.dll(KiUserExceptionDispatcher+0x2e) [0x000000007709127
8]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\lib\ruby\gems\2.0.0\gems\ruby-oci8-2.1.5\lib\o
ci8lib_200.so(DllMain+0x185b8) [0x0000000066B5A8D8]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\lib\ruby\gems\2.0.0\gems\ruby-oci8-2.1.5\lib\o
ci8lib_200.so(DllMain+0x2afc) [0x0000000066B44E1C]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\lib\ruby\gems\2.0.0\gems\ruby-oci8-2.1.5\lib\o
ci8lib_200.so(Init_oci8lib_200+0xae) [0x0000000066B41BCE]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(dln_load+0x1d3) [0x
000000006F101643]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_vm_call_cfunc+0x
12c) [0x000000006F27E1CC]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_require_safe+0x4
1b) [0x000000006F14C89B]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_error_arity+0x12
5) [0x000000006F26C525]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_funcall2+0x4c2)
[0x000000006F27BA22]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_vm_localjump_err
or+0x1b01) [0x000000006F270611]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_vm_localjump_err
or+0x5c89) [0x000000006F274799]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_iseq_eval+0x193)
[0x000000006F27DC13]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_rubylevel_errinf
o+0x5e3) [0x000000006F14ADA3]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_require_safe+0x4
4e) [0x000000006F14C8CE]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_error_arity+0x12
5) [0x000000006F26C525]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_funcall2+0x4c2)
[0x000000006F27BA22]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_vm_localjump_err
or+0x1b01) [0x000000006F270611]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_vm_localjump_err
or+0x5c89) [0x000000006F274799]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_iseq_eval_main+0
x1e0) [0x000000006F27DE40]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(rb_check_copyable+0
x31f2) [0x000000006F1470F2]
c:\ruby\ruby-2.0.0-p0-x64-mingw32\bin\x64-msvcrt-ruby200.dll(ruby_run_node+0x51)
[0x000000006F1499E1]
[0x0000000000402D14]
[0x00000000004013D7]
[0x00000000004014F8]
C:\Windows\system32\kernel32.dll(BaseThreadInitThunk+0xd) [0x0000000076E3652D]

-- Other runtime information -----------------------------------------------

* Loaded script: -e

* Loaded features:

0 enumerator.so
1 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/x64-mingw32/enc/encdb.so
2 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/x64-mingw32/enc/windows_1
251.so
3 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/x64-mingw32/enc/trans/tra
nsdb.so
4 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/x64-mingw32/rbconfig.rb
5 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/compatibility.rb

6 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/defaults.rb
7 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/deprecate.rb
8 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/errors.rb
9 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/version.rb
10 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/requirement.rb
11 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/platform.rb
12 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/specification.rb

13 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/exceptions.rb
14 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/defaults/operati
ng_system.rb
15 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/x64-mingw32/enc/utf_16le.
so
16 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/x64-mingw32/enc/trans/utf
_16_32.so
17 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_
gem.rb
18 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/core_ext/kernel_
require.rb
19 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems.rb
20 c:/ruby/ruby-2.0.0-p0-x64-mingw32/lib/ruby/2.0.0/rubygems/path_support.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.




Thread View

Thread Author Date
oci8lib_200.so: [BUG] Segmentation faultMax Mustermann2013-04-15 16:44
      RE: oci8lib_200.so: [BUG] Segmentation faultKubo Takehiro2013-04-16 00:59
            RE: oci8lib_200.so: [BUG] Segmentation faultMax Mustermann2013-04-16 15:25
                  RE: oci8lib_200.so: [BUG] Segmentation faultMax Mustermann2013-04-17 14:31
                        RE: oci8lib_200.so: [BUG] Segmentation faultKubo Takehiro2013-04-19 03:19
                              RE: oci8lib_200.so: [BUG] Segmentation faultKubo Takehiro2013-04-19 22:05
                                    RE: oci8lib_200.so: [BUG] Segmentation faultMax Mustermann2013-05-15 13:39

Post a followup to this message