Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread

 

By: Mike Wilson
RE: install on Windows failed - sqlite3.h... [ reply ]  
2006-10-02 16:57
Pleased to hear it worked.

By: Emily Bache
RE: install on Windows failed - sqlite3.h... [ reply ]  
2006-10-02 13:55
Thankyou very much for your help. It worked fine once I downloaded sqlite3-ruby-1.1.0-mswin32.gem I'm glad the solution was so simple.

Regards,
Emily Bache

By: Mike Wilson
RE: install on Windows failed - sqlite3.h... [ reply ]  
2006-09-18 12:05
I think you are trying to install the wrong gem. The one you have isn't compiled, so it tries to compile the library as part of the installation procedure. (It isn't a "pure" Ruby library, it needs a separately compiled interface to sqlite).

Try downloading sqlite3-ruby-1.1.0-msvcrt-bin.zip or sqlite3-ruby-1.1.0-mswin32.gem. I'm pretty sure both of those have pre-compiled binaries. I tried both but I can't remember which one did the trick.

Unless someone can remember exactly how to do it, you may still need to experiment a little. If you get really stuck, let me know and I will re-install mine from scratch and keep a note of exactly what I need to do.

By: Emily Bache
install on Windows failed - sqlite3.h... no [ reply ]  
2006-09-18 11:09
I'm trying to install sqlite3 on my windows 2000 machine. I have downloaded sqlite and have sqlite3.exe and sqlite3.dll in C:\sqlite This is also on my $PATH. I dowloaded the gem file for sqlite (I am behind a firewall that won't let gem get stuff remotely, but this has not stopped me installing other gems I have downloaded).
I get output like this:
-------
C:\ruby>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install sqlite3-ruby -- --with-
sqlite-dir "C:\\sqlite"
Attempting local installation of 'sqlite3-ruby'
Building native extensions. This could take a while...
ERROR: Error installing gem sqlite3-ruby[.gem]: ERROR: Failed to build gem native extension.
Gem files will remain installed in c:/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0 for inspection.
ruby extconf.rb install sqlite3-ruby -- --with-sqlite-dir C:\\sqlite\nchecking
for sqlite3.h... no


Results logged to c:/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/ext/sqlite3_
api/gem_make.out

----------

There are several posts on this list from people who have had trouble with this and the advice seems to be to create a softlink to the file so ruby can find it. However, I can't find a .h file at all in the files I have downloaded. I just have a .exe and a .dll. This is Windows after all.

Any help gratefully appreciated.

Emily Bache