Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread

 

By: Ellery Ames
RE: instiki installation issue [ reply ]  
2012-03-02 20:19
Thanks for the quick reply Jacques!

An out of date package manager might have been my problem since I switched from mac os 10.4 to 10.6 without updating Fink.

I decided to give Homebrew a try. I ran

$ brew install sqlite

which presume (due to my success) installed the necessary libraries.

So I am up and running and very excited!

Thanks!
-Ellery

By: Jacques Distler
RE: instiki installation issue [ reply ]  
2012-03-02 06:12
>So I think my first question is how do I tell "ruby bundle" to use the correct version of ruby?

You have the right version of Ruby (1.9.2's gems are installed in /usr/local/lib/ruby/site_ruby/1.9.1).

> $ sudo apt-get install libsqlite3-dev

I assume that means you are using the Fink package manager???

If so, you might try

$ sudo fink install libsqlite3-dev

instead.

By: Ellery Ames
instiki installation issue [ reply ]  
2012-03-01 22:19
Greetings!

I've been trying to get instiki up and running following <http://golem.ph.utexas.edu/wiki/instiki/show/Installation>. I am running mac os 10.6.8 snow leopard and ruby 1.9.2 patch 290. I updated by gems as directed in step 1 of above instructions, then cd'd into the /instiki-svn and attempted

$ ruby bundle

which gives the following error

"Installing sqlite3 (1.3.5) with native extensions /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:552:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)"

One obvious issue seems to be that this is referencing ruby 1.9.1 in /usr/local/lib/ruby/site_ruby/ and not 1.9.2 in /usr/local/bin/

I note the following

$ which ruby
/usr/local/bin/ruby

$ ruby -v
ruby 1.9.2p290 (2011-07-09 revision 32553) [i386-darwin10.8.0]

So I think my first question is how do I tell "ruby bundle" to use the correct version of ruby?

In several hours of searching the internet for folks with similar issues I found that some people had solved similar problems by obtaining the library "libsqlite3-dev" so I tried

$ sudo apt-get install libsqlite3-dev

which results in

Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package libsqlite3-dev

This also puzzles me.

Could anyone offer help?

These issues are probably due to my unfamiliarity with the details of computers, and I apologize if they are very basic.

Thanks!
-Ellery