Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread

 

By: Daniel Berger
RE: Problem using require "'windows/pipe'" [ reply ]  
2009-08-27 19:18
Now it looks like you don't have win32-api installed. You'll have to build it from source if you don't want to use the gem.

Regards,

Dan

By: Christopher Smith
RE: Problem using require "'windows/pipe'" [ reply ]  
2009-08-24 20:59
Scratch the part about fxri, after the windows-pr install it breaks there now too. The message is:

uninitialized constant Win32::API::LoadLibraryError

Is there no way to use the pipes lib with a copy of ruby that dose not have Gems installed?

By: Christopher Smith
RE: Problem using require "'windows/pipe'" [ reply ]  
2009-08-24 20:47
I raked windows-pr and still get the same result. Also, I changed the quotes in my test app but still get the same error.

What is the significance of changing the quotes?

Also why can I require pipe in fxri and not in my test file or the example?

By: Daniel Berger
RE: Problem using require "'windows/pipe'" [ reply ]  
2009-08-24 18:36
You must have windows-pr installed. Most people rely on rubygems to install dependencies properly. I could modify the Rakefile to blow up if you don't have windows-pr installed when doing a manual install, but I can't automatically add it if you don't already have it installed. Not without Rubygems.

Regards,

Dan

By: Christopher Smith
RE: Problem using require "'windows/pipe'" [ reply ]  
2009-08-24 17:55
Excellent! is there a easy way to set up the lib to work with out windows-pr or manually add it into the dependencies?

By: Daniel Berger
RE: Problem using require "'windows/pipe'" [ reply ]  
2009-08-24 16:48
Hi Christopher,

Manually installing it like that doesn't automatically pull in the dependencies. You'll need to install windows-pr first.

Also, be sure to 'require "win32/pipe"' in your actual code.

Regards,

Dan

By: Christopher Smith
Problem using require "'windows/pipe'" [ reply ]  
2009-08-24 16:42
I am trying to use the pipes extention of the win32 lib but get an error when i try to run the example code.

I started this by downloading the .zip and installing it using "rake install" which provided me with:
cp lib/win32/pipe.rb C:/Ruby/lib/ruby/site_ruby/1.8/win32
cp lib/win32/pipe/client.rb C:/Ruby/lib/ruby/site_ruby/1.8/win32/pipe
cp lib/win32/pipe/server.rb C:/Ruby/lib/ruby/site_ruby/1.8/win32/pipe

When i try to run the example code I get an error like:
C:/Ruby/lib/ruby/site_ruby/1.8/win32/pipe.rb:1:in `require': no such file to load -- windows/pipe (LoadError)

however if if load good ole fxri and type:
require 'windows/pipe'

i get:
=> true

So what gives?