Forums | Admin

Discussion Forums: help

Start New Thread Start New Thread

 

By: Travis Robertson
RE: Error when trying to install Contacts gem [ reply ]  
2008-03-04 17:17
Ok...as usual, I figured it out after posting this request. I could spend hours working on a problem only to post a question then immediately solve it.

In case someone else has this problem on a Mac (especially Leopard):

Install XTools under the optional installs folder on the Mac Installation disk. I had upgraded to Leopard, but had not upgraded my XTools installation. I was still using the old version of XTools that came with 10.4. Ran the Leopard version...Boom...Fixed.

Thanks!

By: Travis Robertson
Error when trying to install Contacts gem [ reply ]  
2008-03-04 17:04
Hey Everyone,

I'm trying to install the Contacts gem and I'm getting the following error:

sudo gem install --remote contacts
Bulk updating Gem source index for: http://gems.rubyforge.org
Building native extensions. This could take a while...
ERROR: Error installing contacts:
ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb install --remote contacts
can't find header files for ruby.


Gem files will remain installed in /Library/Ruby/Gems/1.8/gems/json-1.1.2 for inspection.
Results logged to /Library/Ruby/Gems/1.8/gems/json-1.1.2/ext/json/ext/parser/gem_make.out

I've installed gems from other repositories without any problems. However if I run gem list --remote and try to install any of the gems listed, I get the above error. Any ideas? I used the installation instructions for Mac over at HiveLogic.

Thanks in advance!