Forums | Admin

Discussion Forums: open-discussion

Start New Thread Start New Thread

 

By: Matan Nassau
RE: "couldn't start ruby script" on ubuntu li [ reply ]  
2007-12-15 20:29
thanks! running on ubuntu 7.10, after changing the paths from "/home/..." to "~/..." and then wrapping with (expand-file-name "~/...") solved the issue.

cheers!

By: Pavol Murin
RE: "couldn't start ruby script" on ubuntu li [ reply ]  
2007-11-29 10:44
I also found that the path to the ruby file (ri-emacs.rb) must be absolute. I solved it in changing .emacs lines to:

(setq ri-ruby-script (expand-file-name "~/emacs-modes/ri/ri-emacs.rb"))
(autoload 'ri "ri-ruby.el" nil t)

change the first line accordingly to your path.

good luck, muro

By: Eric Schulte
RE: "couldn't start ruby script" on ubuntu li [ reply ]  
2007-09-30 17:57

I have this working on my osx system. Both from executing (ri "Array")
or from running the ri command from inside ruby mode.

If it helps my setup is as follows...

;;; ri (ruby interactive documentation)
;;
;; http://rubyforge.org/projects/ri-emacs
;;
(setq ri-ruby-script "/Users/eschulte/emacs/elisp/ri-emacs.rb")
(autoload 'ri "/Users/eschulte/emacs/elisp/ri-ruby.el" nil t)
;; Bind the ri command to a key.
;; Method/class completion is also available.
(add-hook 'ruby-mode-hook (lambda ()
(local-set-key "\C-cd" 'ri)
(local-set-key "\C-cf" 'ri-ruby-complete-symbol)
(local-set-key "\C-ca" 'ri-ruby-show-args)
))


replace the paths with those for your system. Also make sure you have
the 'ri' command installed on the system. From my command line...

(eschulte@eschulte~)ri -v
ri v1.0.1 - 20041108

and that the path to the ri executable is part of your emacs exec-path.

That's all I can think of, hope it helps.

- Eric



By: Marco Guilmette
RE: "couldn't start ruby script" on ubuntu li [ reply ]  
2007-09-30 14:18
I'm having the same problem on OS X. I also get the error when I do (ri "Array") interactively. Here's the backtrace:

Debugger entered--Lisp error: (error "Couldn't start ruby script")
signal(error ("Couldn't start ruby script"))
error("Couldn't start ruby script")
(cond ((not ...) (delete-process ri-ruby-process) (error "Couldn't start ruby script")))
(save-excursion (set-buffer ri-ruby-process-buffer) (set-process-filter ri-ruby-process (quote ri-ruby-process-filter-expr)) (ri-ruby-check-process ri-ruby-process-buffer) (accept-process-output ri-ruby-process ri-startup-timeout) (goto-char (point-min)) (cond (... ... ...)))
(unwind-protect (save-excursion (set-buffer ri-ruby-process-buffer) (set-process-filter ri-ruby-process ...) (ri-ruby-check-process ri-ruby-process-buffer) (accept-process-output ri-ruby-process ri-startup-timeout) (goto-char ...) (cond ...)) (set-process-filter ri-ruby-process t) (kill-buffer ri-ruby-process-buffer))
(let ((ri-ruby-process-buffer ...)) (unwind-protect (save-excursion ... ... ... ... ... ...) (set-process-filter ri-ruby-process t) (kill-buffer ri-ruby-process-buffer)))
ri-ruby-process-check-ready()
(cond ((or ... ...) (setq ri-ruby-process ...) (process-kill-without-query ri-ruby-process) (ri-ruby-process-check-ready)))
ri-ruby-get-process()
ri-ruby-process-get-lines("DISPLAY_INFO" "Array")
(let* ((method ...) (info ...)) (cond (info ...) (...) (t ... ... ...)))
ri("Array")
eval((ri "Array"))
eval-last-sexp-1(nil)
eval-last-sexp(nil)
call-interactively(eval-last-sexp)




By: Kristof Bastiaensen
RE: "couldn't start ruby script" on ubuntu li [ reply ]  
2007-08-19 19:40
I have no idea at the moment. Could you tell me which version of Emacs you are using?

By: Eric Schulte
"couldn't start ruby script" on ubuntu linux [ reply ]  
2007-07-25 17:49
Hi,

I have been trying for some time to get this working on my ubuntu 7.04 box.

The pointers to the script in dot.emacs are all correct, and the script runs successfully from the command line (even returns appropriate responses if I pass in commands by hand), however when I run (M-x ri) from emacs I get the "couldn't start ruby script" response.

I have tried this with and without RUBYOPT=rubygems set in emacs. Any ideas why this could be failing? Any pointers to ways to get more debug info?

Thanks,
Eric