Posted By: Luis Lavena
Date: 2010-06-07 03:08
Summary: RubyInstaller Final Packages - 1.8.6, 1.8.7 and 1.9.1!
Project: Ruby Installer for Windows

I'm pleased to announce the release of final RubyInstaller packages.

For those not already familiar with RubyInstaller, these versions
continue the great work started with the original One-Click Installer
by providing both 1.8 and 1.9 versions of MRI Ruby for Windows.

RubyInstaller is powered by GCC compiler, we provide as
convenience an optional Development Kit, which now makes possible
to install RubyGems that, until today, were not readily or easily
available to Windows users.

This release also focuses on improving the installation process and
ensuring a much more pleasant experience for existing and new users of
Ruby on Windows.

= Before installing

If you're upgrading from previous RubyInstaller packages, please
uninstall these versions before proceeding. Don't worry, any gems
that you installed or compiled since installed will not be removed.

Since the new RubyInstaller uses a different compiler, we highly advise
that you avoid attempting to install over any previous One-Click Installer
installation, or any other variant versions (InstantRails, BitNami, etc.)

We recommend that you backup your previous installation, take note of the
details, your installed gem list, etc and proceed to completely uninstall
any legacy installations.

= Verify the downloaded files

The following are the MD5 signatures of each component:

Installers:

233d6b3ddc4c61436b075b51254cd138 *rubyinstaller-1.8.6-p398.exe
9ffa7dfdd336340a924f5d34b686ab58 *rubyinstaller-1.8.7-p249.exe
e686ae092d05c534cbc06490a56fb357 *rubyinstaller-1.9.1-p378.exe

Binary Packages:

70f7b23315e6d94cf24ea4b343573818 *ruby-1.8.6-p378-i386-mingw32-1.7z
77b4122e265e252964b2b1c356c2e651 *ruby-1.8.7-p249-i386-mingw32-1.7z
fdb18c362d85d11faab377762ecb0e69 *ruby-1.9.1-p378-i386-mingw32-1.7z

CHM Help Files:

1e95a8010ca5d06ade9eec889fd0fc65 *ruby-1.8.6-p378-doc-chm-1.7z
968de52735c1710913518e0f5a0e87c2 *ruby-1.8.7-p249-doc-chm-1.7z
dfc6ac01f6df945ac0a3a0c2825fcee6 *ruby-1.9.1-p378-doc-chm-1.7z

Please note that due a limitation of RubyForge file manager system,
Binary packages and CHM files included a '-1' in their filenames.

Changes since last RC2:

=== Final / 2010-06-06

* Enhancements:
* Installers now record version information in the registry [jonforums]
* Increase file descriptors for 1.8.x based compilations. Fixes #27465.
* Upgraded ZLib to 1.2.5
* Upgraded OpenSSL to 0.9.8n
* Upgraded RubyGems to 1.3.7

Latest News
TZInfo::Data v1.2014.2 Released
    Philip Ross - 2014-03-25 22:32
TZInfo v0.3.39 Released
    Philip Ross - 2014-03-09 20:23
TZInfo::Data v1.2014.1 Released
    Philip Ross - 2014-03-09 20:00
Automatic Ruby 14.2.0 has been released!
    id 774 - 2014-02-26 06:23
kramdown 1.3.2 released
    Thomas Leitner - 2014-02-16 08:35

 

Forums | Admin

Discussion Forums: rubyinstaller-final-packages---1.8.6--1.8.7-and-1.9.1-

Start New Thread Start New Thread

 

Topic Topic Starter Replies Last Post